本站同款虚拟主机(联系博主更优惠)

LNMP2.0正式版发布

又是一年六一,军哥也如约而至发布了LNMP2.0的正式版,新增了PHP8.2的支持,添加RHEL 9、CentOS Steam 9、Oracle 9、Alma 9、Rocky 9支持等,具体更新日志如下

2023年6月1日发布LNMP 2.0正式版

  • 增加PHP 8.2支持;
  • 添加MySQL 5.5、5.6二进制安装和升级方式;
  • 添加MySQL 8.0 aarch64架构下二进制安装方式;
  • 添加MariaDB二进制安装和升级方式;
  • 添加zblog伪静态;
  • 添加php-redis测试脚本;
  • 添加Nginx编译参数–with-http_realip_module参数;
  • 添加RHEL 9、CentOS Steam 9、Oracle 9、Alma 9、Rocky 9支持;
  • 添加MariaDB 10.11,移除MariaDB 10.3;
  • 增加Amazon Linux 2023支持;
  • 增加MySQL升级到MariaDB时二进制安装方式;
  • 增加OpenCloudOS支持;
  • 增加SourceGuardian PHP 8.2支持;
  • 优化低版本PHP在新Linux发行版下的支持;
  • 优化Anolis OS 7支持;
  • 优化Oracle 7支持;
  • 优化SourceGuardian安装脚本;
  • 优化php-memcached安装脚本;
  • 优化离线安装;
  • 优化lua安装流程并使用最新版本;
  • 优化RHEL有订阅时不使用CentOS源;
  • 优化MariaDB 10.5+版本升级;
  • 优化PHP 7.0及以下版本在高版本Linux版本下的支持;
  • 优化PHP 5.5-5.6在AARCH64架构下的支持;
  • 优化composer安装脚本;
  • 优化MySQL 5.5,5.6,5.7在OpenSSL3.0下安装失败的问题;
  • 升级Nginx至1.24.0;
  • 修复apache2.4邮箱设置问题;
  • 国内centos源默认使用ustc源;
  • 调整acme.sh默认使用RSA证书;
  • 更新诸多软件版本;
  • 其他一些功能优化及调整……
  • CentOS/RHEL/Fedora/Debian/Ubuntu/Raspbian/Deepin/Aliyun/Amazon/Mint Linux发行版
  • 需要5GB以上可用空间,MySQL 5.7,MariaDB 10至少9GB剩余空间,MySQL8.0最新版至少25GB以上,如空间不够且是x86或x86_64架构MySQL可以选择Generic Binaries安装。
  • 需要128MB以上内存(128MB小内存VPS,Xen需有SWAP,OpenVZ至少要有128MB以上的vSWAP或突发内存),注意小内存请勿使用64位系统!
  • 安装MySQL 5.6或5.7及MariaDB 10必须1G以上内存,更高版本至少要2G内存!
  • 安装PHP 7及以上版本必须1G以上内存!
  • VPS或服务器必须设置好可用的yum或apt-get源并确保能正常工作,离线安装需要增加 CheckMirror=n 参数!
  • 不要在非常新的Linux发行版上安装旧的PHP/MySQL版本,同理不要在旧的Linux发行版上安装非常新的PHP/MySQL版本。
  • Linux下区分大小写,输入命令时请注意!
  • 如有通过yum或apt-get安装的MySQL/MariaDB请自行备份数据等相关文件!
  • CentOS 5、6、8,Debian 6、7、8或更低版本官网已经结束支持无法直接使用,需自行更换vault或archive源!
  • CentOS 6、8请用lnmp 1.9+版本进行安装!
  • Ubuntu 18+,Debian 9+,Mint 19+,Deepin 15.7+及所有新的Linux发行版只能使用1.7+进行安装!
  • PHP 7.1.*以下版本不支持Ubuntu 19+、Debian 10+等等非常新的Linux发行版!
  • 阿里云Ubuntu 14.04和22.04系统模版有问题不要用!!!要用的话论坛找解决方法
  • PHP 7.4升级或安装必须CentOS 7+,Debian 8+,Ubuntu 16.04+且必须使用1.7+!!!
  • MySQL 8.0.23以下版本升级或安装必须CentOS 8+,Debian 9+,Ubuntu 16.04+且必须使用1.7+!!!
  • MySQL 8.0.24以上版本升级或安装必须Debian 11+,Ubuntu 20.04+,Fedora 33+,CentOS 9等gcc 10+的版本且必须使用1.9+,不满足要求请选择(Generic Binaries)二进制方式!!!
  • MariaDB 10.*以上版本升级或安装必须CentOS 8+,Debian 10+,Ubuntu 18.04+等cmake版本高于3的系统或自行升级cmake!!!不满足要求使用lnmp 2.0选择(Generic Binaries)二进制方式。

安装脚本:

wget http://soft.vpser.net/lnmp/lnmp2.0.tar.gz -cO lnmp2.0.tar.gz && tar zxf lnmp2.0.tar.gz && cd lnmp2.0 && ./install.sh lnmp
© 版权声明
THE END
喜欢就支持一下吧
点赞6 分享

cloudcone美国VPS

cloudcone美国VPS